Tecnología

AMD lucha para ser excluida del parche para Intel, ya que sus CPUs son seguras y el parche también los afecta en el rendimiento

Intel está luchando en secreto contra una importante vulnerabilidad de seguridad en sus procesadores x86. La vulnerabilidad a nivel de hardware permite el acceso no autorizado a la memoria entre dos máquinas virtuales (VM) que se ejecutan en una máquina física, debido a la implementación defectuosa de Intel en el conjunto de instrucciones de virtualización a nivel de hardware.

Los parches del kernel para el sistema operativo solucionan el problema de seguridad, pero tiene un enorme costo de rendimiento que afectan al equilibrio entre términos de precio/rendimiento de elegir procesadores Intel en centros de datos a gran escala y proveedores de computación en la nube en comparación con los procesadores de AMD.

Los procesadores Ryzen, Opteron y EPYC son inherentemente inmunes a esta vulnerabilidad, pero los parches del núcleo parecen afectar el rendimiento de los procesadores AMD e Intel.

La inspección minuciosa de los parches del kernel revela un código que obliga a las máquinas que ejecutan todos los procesadores x86, Intel o AMD, a parchearse, independientemente del hecho de que los procesadores AMD sean inmunes.

AMD busca que al menos el kernel de Linux incluya una línea de código como “(c-> x86_vendor! = X86_VENDOR_AMD)“, mientras que si el procesador usado no es AMD se marque como “X86_BUG_CPU_INSECURE“.

Esto muestra que las solicitudes de AMD están siendo rechazadas por los desarrolladores del Kernel. Sus intenciones son lógicas ya que los procesadores AMD son inmunes, dado que el software parcheado inflige penalidades de rendimiento en los procesadores Intel y AMD creando un “campo de juego nivelado” de amigos.

Entonces AMD debería presionar para que se lo excluya de este parche, ya que solo es un problema de Intel….

Fuente: HD Tecnología

Dejá tu comentario:

Union Radio

Parlantes
Union digital